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Section 6: Updates

An Internet Connection is required for all updates.
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SMARTLINK UPDATES OVERVIEW

There are two methods of updating the software, firmware, and EFI Map library; through
the SmartLink software’s update features, and through the ThunderMax website.
Occasionally some customers have issues updating their software through the
integrated SmartLink update functions; however it is rarely the fault of the
SmartLink software. The main reason for problems is quite simple, for some reason,
your computer is not allowed to send and receive automatic requests for information
from an outside FTP server. Since this is a function that’s automatically contacting an
FTP server for information, some networks or computers will deny the SmartLink
request for data transfer before it's even allowed to contact the FTP server.

Key reasons for not being able to update through the integrated Update functions are as
follows:

1.) Your network is highly secured and does not allow automatic requests for
unknown FTP servers.

2.) Your computer has a security or firewall setting that is not allowing SmartLink
to automatically send information to and from the SmartLink FTP server.

3.) You are using your office computer that was setup by your professional IT
department. Many of the updating problems that are seen by Product Support are
related to “business” computers where the user (you) does not have administrator
privileges, and many network features are locked out.

These are simply not problems that the SmartLink support staff can help you with, given
the number of operating systems in use today, and the complexity of modern network
security. If your computer is administered by your IT department, you need to make
them aware of the problem, but only if they are ok with you having personal (non
business related) programs installed on the computer. Otherwise, you will need to
purchase your own computer, and your own internet connection, to take advantage of
the automatic update functions. However, this is completely unnecessary! ALL updates
are available through any web browser.

If you are experiencing problems with the automatic update functions through the
software, you are not out of luck! Simply go to the ThunderMax website
(www.Thunder-Max.com), and manually download the latest Software, Firmware, or
Tuning Manual release. It is not worth the effort if you cannot get the update function to
work and do not know enough about your computer or network to correct the problem. If
you do not control the computer or network settings, you will never solve the problem on
your own, and there’s nothing that the Product Support team can do to help.
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UPDATING THE SMARTLINK SOFTWARE

To maintain the most current version of SmartLink IV, use the update function in the
software. An Internet Connection is required for all updates.

Select Configure > SmartLink Update to begin the update process, as shown below.
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The following window will appear:
Software Updates

Check to seeif you need updates for your software.

Click Check to search for updates, Cancel to Exit.

Check | Caricel
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One of two choices will appear:

Installing Updates

. There are no updates currently available for download.
Software is
u p tO d atel Installation status:
No action
required.
Review and Install Updates
NeW Dovenload Size [total) . 1493 MB
Software
Availablel Wwebllpdate2008_1_7 [Update 1 of 1)....
Update zearch completel
Proceed
Forward
with the
Update
Process
Updates found....
ARREEENERREERRERREERENRRRERENEREEEEEE
Inztall | Cancel |

Follow the instructions provided by the SmartLink IV update windows to update your
version of SmartLink IV. When complete, open SmartLink IV and select Help > About
SmartLink... to check the version number that is currently installed on your computer.
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UPDATING THE BASE MAP DEFINITIONS

To ensure that you have the complete and up to date Base Map Library, select the
“Check Internet for Updates” button on the “Base Map Name Encoding” window, as
shown below.
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Chedk Internet For Updates Select BaseMap | Date
Load BaseMap |

You must be connected to the internet to update the Base Map Definitions as well
as retrieving any available new Base Maps. The SmartLink IV Installation CD does
contain the base map library; however it is only as current as the CD itself. Versions
2008 and later will automatically download any new base map files when the definition
file is updated. Previous versions will only download a list of available base map
choices. Again, an internet connection is a requirement for updating the
SmartLink IV software / base maps.

It is simply good practice to update the definition file when searching for a new Base
Map file. Not only are new maps constantly being created, but the older Base Maps are
updated occasionally as well. Once updated, you may proceed with selecting an
appropriate Base Map for the current engine combination you are working with.

If you are satisfied with the operation of your current Base Map, chances are a new
Base Map will not make a significant difference to the operation of the motorcycle.
Updated maps could contain spark curve or fuel management changes, or even
different fuel economy strategies.

163



Updates

UPDATING THE FIRMWARE IN YOUR THUNDERMAX ECM

For any modules with a Firmware version of 3.2 or higher, you can update the firmware,
if an update is available, through the SmartLink software. You must be linked to the
ThunderMax ECM to update the firmware in the module. An Internet connection is
required to download the Firmware. Once the firmware file is downloaded, you do not
have to be connected to the internet to upload the new Firmware to the ThunderMax
ECM. There are two stages in updating the Firmware in the ThunderMax ECM.

Stage 1: Check for an update, and download the latest Firmware onto your
computer.

Stage 2: Link to the ThunderMax ECM and upload the newly downloaded
Firmware to the module.

Both stages are fully covered in the following pages. Both require that you are linked to
the ThunderMax ECM, and have read the module map and settings.

To begin the Firmware update procedure:
1.) Link to your ThunderMax ECM
Link
2.) Select File > Read Module Maps and Settings

1 USMLIY | Zippers End User SEW7010-ZIF

File EFIMaps Map Editing Tools Configure Mo

Tew Chrl+M J

Qpen... Chrl+O -
Close Yol
Save Chrl4+3 —

Save As...

1 ZCYELIBCEF111804
2 ZCYELIBCFRO10307 Jde
3 HDTSSJVCEEDL0307 5pa
4 HBUSSGSGXEN1 2406

READ Module Maps and Settings  Ctrl+R

WRITE Module Maps and Settings  Crrl+Ww

Exit
= S
[ Hl— — — " """
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Stage 1: Downloading an Updated Firmware

Select Configure > Firmware > Check for Firmware Upgrade to see if there is an
updated Firmware available for your ThunderMax ECM.

= SMLIY | Zippers End User SPWJZ010-ZIPB | - HOFJPTYCUGO40307.SLK  (FileBaseMap:

File EFIMaps MapEditing Tools Relie®{=8 Monitoring  Window  Help
Select Com Port " | —

Tuning Maps ] -

g P Firmware Check For Firmware Upgrade =
+- Front Cylinder Fuel Product Configurations ] I
4 Rear Cylinder Fusl authorize Product Upgrade Module Firrmaare Mow !
+- A0 Curves Closed Loop MODULE Settings. ... EIEEARTED
+|- Ar Fuel Ratio Curves

] AFR Rear
+- Ignition Tirning MODULE Setkings. .. 3 J |
41 Ignition Timing S TPS ) 330 AFR
. SmartLink Update

+1- Air/Fuel TPS @ rpm At | AFF Target |

If an updated firmware is available for your ThunderMax ECM, the following window will
appear:

Multiple Files Found %]

Select Desired Base Map File.......

EFI_THUMDERMAX-01 Mersionda 12-04-05.619 (Latest Yersion)

Cancel

If you select the “OK” button, the firmware download will begin. Once completed, the
following window will appear.

Firmware Download Completed E|

\:I) Firmware upgrade File saved: C:\Documents and Setkingshall Users)Documents Thunder

-

HeartismartLinkIvZippersiFirmwarelJpgradestEFT_THURDERMAx-01 Yersionda_12-04-08.619
Fram the main menu run Upgrade Module Firmmware Mow' to upgrade the module using this file.
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Stage 2: Uploading a New Firmware Version into the ThunderMax
ECM

~ Link Link to the ThunderMax ECM, and Read Module Maps and Settings.
SmartLink 2008.0.2 and newer will automatically read the map from your ECM before
any firmware upgrade can begin.

To upload the new Firmware to the ThunderMax ECM, select Configure > Firmware >
Upgrade Module Now, as shown below. You must be linked to the ThunderMax ECM
to perform any firmware upgrades.

[ SMLIY | Zippers End User SEW70M10-ZIPB | - HOFJPTYCUGO40307 51K (FileBaseMap:

File EFIMaps MapEditing Tools Eellis®{E=N Monitaring  Window  Help

. Select Caom Port 3
Tuning Maps lect Com Por | —— |
Firrware
+- Frant Cylinder Fuel Product Configurations
+- Rear Cylinder Fuel Autharize Product
+- 1AE Curves Closed Loop MODILE Settings. ... S
+1- Air Fuel B atio Curves
) AFF Rear

+- Igrition Tirming MODULE Settings. .. b J |
+1- Inition Timing %S TPS . 20 ol

. SmarkLink Update
+- Air/Fuel- TPS @& rpm idna—— AFR Target |

The following notice will appear, prompting you to continue:

Firmware Upgrade - Module Read X

You are about ba perfarm a firmware upgrade to the module,
The current module map and configuration will be READ before performing this upgrade,
ontinue with the Firmware upgrade now?
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Once selected, the following window titled “Module Detection” will appear:

Module Detection

To Initialize the Firmware Upgrade Frocess......
1. Turn the MODULE power OFF for 20 seconds.
2. Turr the MODULE povwer OM.

3. The software will continue automatically.

PLEASE CYCLE THE MODULE POWER MOy

IMPORTARNT MOTICE
[ WODULE DETECTIOMN fails to occur........

1. The moduleffirmware may be carrupted.
2. The moduleffirmware wersiaon DOES MOT allow upgrade.

Flease contact the manufacturer to upgrade ar repair the
madule.

Follow the instructions on the “Module Detection” window:
1.) Turn off the Ignition Switch for 20 seconds.
2.) Turn on the Ignition Switch

The update process will now automatically begin. The following window will appear,
allowing you to select the most recent version of the Firmware that you've downloaded
onto your computer. Select the most recent version of the firmware, and select the
“Open” button, as circled below.

imnarel | porades I‘::F -

- [=er1_THUNDERMAR-01 version4a_12-04-08,B19;
My

Documents

F

Desktop

=

&

My Documents

@

My Carmputer

L =~

MyMNetwork  File name: [EFI_THUNDERM&-0_Versiandd_12-19:06 (+ Open |
Places
Files of type: |FirmWareFi|e$ j arCel
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Once the file has been opened, the following window will appear titled “Module

Detection.” Follow the prompts to continue the firmware upgrade for your ThunderMax
ECM.

Module Detection

Y'ou are aboutto begin the 'Firmware Upgrade Process',

Current kodule Firrmware: 0x48 - 05-03-2008
Update To This Firmware: 0x44-12-04-2008

1. Turn the MODULE power OFF for 20 seconds,
2. Turnthe MODULE povwer OM,
3. Firmware Upgrade will continue autormatically

..............................................

Follow the instructions on the “Module Detection” window:
1.) Turn off the Ignition Switch for 20 seconds.
2.) Turn on the Ignition Switch

If the Firmware upgrade process is successfully initiated, you will see the following
status window appear, titled “Transferring Data.”

Transferring Data

Firmware Download
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Once the transfer completes, the “Module Detection” window will appear again.

Module Detection

Firmware Upgrade Completed MNomally....

1. Turn the MODULE power OFF far 20 seconds.
2. Turn the MODULE power O,

3. The software will continue automatically.

PLEAZE CYCLE THE MODULE POWER MO

Follow the instructions on the “Module Detection” window:
1.) Turn off the Ignition Switch for 20 seconds.
2.) Turn on the Ignition Switch

The software will automatically “WRITE Module Maps and Settings” to complete the
Firmware Upgrade process.

The Firmware is now upgraded in your ThunderMax ECM. To check the firmware
version on your ThunderMax ECM, simply open SmartLink 1V, Link to the ECM, and
select Help > About SmartLink..., as shown below. The “SMLIV” window that pops up
will display the current software and firmware versions.

File EFIMaps Map Editing Tools

Tuning Maps

= SMLIV | Zippers End User SPW7010-ZIPB |

Configure  Monitoring  Window W&

- HETEKGYGAXEDO71607  [FileBaseMap:HETEKG

Front Culinder Fuel
Rear Cylinder Fusl

JALC Curves

Air Fuel R atio Curves
|gnitian Timing

|gnition Timing %5 TPS
AirFugl-TPS & pmi
Module Configuration

o O O Oy

0| = E amartLink, Tuning Manual (pdf) !
Batery Volts Online Help Documents
s |
1214 Wolt  What's New? | ]
Front Cyl. Spark ThunderMax WebSite
7.00 deg Prepare and Send, Module Daka Email !
M Create and Send, Monitor Log Email
V.00 deg
_ Bbout smartlink. ..
Engine Speto | VT T T oo o
0.00 rpm 100.00 I =
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SMLIY Version 2008.1.9

@
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